WordPress Ends Support for PHP 5.2 – 5.5, Bumps Minimum Required PHP Version to 5.6

  • Home / Search engine / WordPress Ends Support…

WordPress Ends Support for PHP 5.2 – 5.5, Bumps Minimum Required PHP Version to 5.6

WordPress has officially ended support for PHP 5.2 – 5.5 and bumped its minimum required PHP version to 5.6. The plan announced last December was to bump the minimum required version in early 2019 and, depending on the results, bump it again to PHP 7 in December 2019. Sites on PHP 5.5 or earlier can still get security updates but will not be able to upgrade to the latest major WordPress version.

Today only 2% of WordPress sites remain on PHP 5.2 . Roughly 20% are on versions 5.5 or earlier. Nearly half of WordPress installs are on PHP 7.0+.

One might wonder why WordPress’ approach isn’t to just bump it all the way up to PHP 7. With its influence and dominant market share, this requirement would inevitably force users to get on board. However, WordPress contributors believe in supporting users who, for whatever reason, need more help upgrading PHP. Steamrolling this requirement has not been the WordPress way, despite years of immense pressure from the developer community.

“Leaving users behind for technical reasons creates a two-folded web with only few being able to leverage its power,” WordPress Core Committer Felix Arntz said. “Collaborating with and supporting these users gives that power to everyone in the long run.”

Gary Pendergast shared a few stats about how effective WordPress 5.1’s PHP update notice has been in prodding site owners to get on newer versions of PHP:

For WordPress 5.0, sites updated their PHP version from PHP For WordPress 5.1 (after adding the update notice), that has increased to a steady 5 basis points per day. Doesn’t sounds like much? Every day, that’s hundreds of extra site owners choosing to go through the (frankly, terrifying) process of updating their PHP version. All they needed was a little extra nudge, and a little bit of information.

Scary EOL notices and attitudes of “well, we’re just bumping our supported PHP version, too bad if you don’t know what to do next” don’t help. Giving people the information they need to help themselves works.

WordPress folks are doing our part to help clean up the ancient PHP installs that are still running a large percentage of the internet, and we’re find that this isn’t an insurmountable problem. It just requires a bit of patience and empathy to solve.

WordPress developers around the web sent out celebration tweets after the news was announced. Although PHP 5.6 is the new minimum required version for running WordPress, the project’s technical requirements page recommends users ask their hosts for PHP version 7.3 or greater. PHP 7+ offers massive performance gains for users and developers will be able to update their plugins to use more modern syntax.

This is big news!!

WPGraphQL has a minimum requirement of PHP 5.6, so it couldn’t even be considered for core until now.

Still a ways to go before we’re ready for serious consideration, but pretty big news. https://t.co/gCbJM9VcRc

— GraphQL for WordPress (@wpgraphql) March 21, 2019

Today only save up to 25% off your total projects cost.

We will take a look at the scope of your project and give you a discounted quote